Tasks not displayed when exported to PDF in macOS Mojave

Thanks for the advise. I already did. I used Liberation Sans which comes in GranttProject’s folder and I get the same result. The tasks in the Gantt Chart in the PDF don’t show up.

Any other recommendation or would you like me to send you the PDF?

Regards.

Can you please share the project file and the result PDF?

Here you are.

Regards.

Plataforma Sitios Web - Plan de Trabajo v0.0.1.pdf (99.1 KB)

Plataforma Sitios Web - Plan de Trabajo.gan (6.2 KB)

What font is chosen as Application Font in the settings? Can you try using Liberation Sans there as well?

I am having the same problem. The tasks are not displaying on pdf using MacOS Mojave.

What font settings do we need to change and where? See screenshots.

Gantt Chart.pdf (70.4 KB)

Try changing Application font in the Application UI settings, e.g. choose Liberation Sans just to check. Also, in the export wizard, choose Liberation Sans as arial substitution.

I chose Liberation Sans as arial subsitute in the export wizard and it still didn’t work. There’s no option for Liberation Sans in the Application UI settings. Should I choose something else?

Yes, try choosing some other font. I think the chooser shows the list of fonts which are installed on the operating system. You can try installing Liberation Sans: https://support.apple.com/en-us/HT201749

Also, are we talking about English symbols?

Hey Dmitry, I was not able to install Liberation Sans using your instructions and the other fonts don’t seem to work. Can you please help?

See screenshot of the left column. The list does not display.

I can’t suggest anything besides playing with the fonts, sorry. In fact I can reproduce the issue on macOS Catalina, with other application font, and it fixes as soon as I change the application font. See the screencast below: task table cells are empty with PT Sans while everything is okay with Tahoma (fonts were chosen pretty much randomly)

ezgif-4-6e61b054728d

I just solved the issue by changing font to Verdana in settings/preferences (two places) and when I export to PDF as well (one place during export). Then I get the activities out.

But the Gantt part is impossible to read. Is there any way to export the Gantt diagram in a format that people can zoom into to read it?

Can you please share the example of your PDF output?

Test.pdf (365.5 KB)

Here it is …

Thanks.

So,

  1. PDF output IS zoomable. You can zoom in and see the details. Here is the screenshot of a part of your PDF.

  2. Why don’t you make the logo a little bit smaller? It eats nearly a half of the vertical space.

It works and it looks good. Thanks a lot.

An update on this:

  • I still don’t know the reason why some fonts may not render some glyphs on macOS.
  • As a workaround, I added Droid Sans Fallback font to GanttProject and made it registering itself in the list of application and chart fonts, so that installation is not required. This font covers a wide range of character sets, including CJK, so hopefully it will be a good fallback font.
  • A few bugs with font registration were fixed. They might be the cause of this issues, however, as I said above, I still can reproduce this issue with e.g. PT Sans font
  • Some logging was added to log what’s going on with the font registration

All this is going to be published in the upcoming GanttProject 3.0 which hopefully will be released by the end of year.

So, this was published in GP 3.0 Release Candidate build. Choosing “Droid Sans Fallback Full H” font in the settings will hopefully fix the issue. The font is shipped with GanttProject and registers in the application automatically.

1 Like

solve the problem
thanks buddy

Hi Dlmitry,

I am struggling with the same problem on my Mac. Just upgraded to GP 31.3102 in order to benefit from this embedded Droid Sans Fallback Full H font. I installed the font in the Font Book of my Mac after downloading it from the net.
I have changed the GP settings to this font as application and chart font. Then I tried exporting my project to .pdf and chose this font as a substitute for ARIAL.
Same result: empty task list with only the bullets.

Do you have any other suggestion?

rgds