"Can't open document ..... (no such file or directory)" OSX Mojave

I have GanttProject 2.8.10 Pilsen (build 2363) on MacOS Mojave 10.14.5

Previously I have been able to open .gan files without issue. Now I am trying to open a .gan file, and get the below error:

Something went wrong

Can’t open document
Unable to open the file: /Users/DSH/Ship (no such file or directory)
/Users/DSH/Ship (no such file or directory)

View Log

I have tried changing the directory in which the file was located. I also tried opening directly from my mail program (MS Outlook). Same error.

Thanks for your help.

Can you please run this command in your Terminal window and post the output?
ls -l /Users/DSH

Thanks. Apparently, there is an issue with opening files with spaces in the name. I’ll check it. Meanwhile, you can rename your Ship Schedule JULY 15th 2019.gan to e.g. Ship_Schedule_JULY_15th_2019.gan and I think it will open fine.

That fixed it. Thanks!

FYI: I removed your reply just not to expose the contents of your home directory to the public.

Thank you for that, I had not considered the exposure.

Hello Dmitry - I noticed one additional item here - it is also problematic if there is a space in any of the file path, not just the file name. Please let me know if/when you have a fix for this.

What GanttProject distro do you use? Regular one or “fallback for Mojave”?