GanttProject demande Java 11

GanttProject ne fonctionne plus sur mon windows 10, Il demande Java 11. J’ai essayé Liberica JDK comme suggéré, plusieurs problèmes et toujours incapable de faire fonctionner mon Projet. Mais pourquoi donc qu’on me demande Java 11 alors que ca fonctionnait très bien avant hier.


We do not speak French, sorry. This is your message, translated with Google Translate:

GanttProject no longer works on my windows 10, It requires Java 11. I tried Liberica JDK as suggested, several issues and still unable to get my Project to work. But why am I being asked for Java 11 when it was working very well before yesterday.

Please consider writing in English for better understanding.

GanttProject 3.2 for windows (exe file) comes with its own Java Runtime. You don’t need to download Java separately. Please explain what exactly do you mean as “no longer works”. What you do and what you get. A screencast would be awesome.

Tks for your answer, I am trying to install version 3.2.3200 as you mentioned but still unable to get it to work. I will come back with a more complete answer tomorrow.

Tks again

So far I was able to reinstall version 3.1.3100 yesterday, got it working and then the same thing happened. I retried installing it, but got the same request for java 11. I also tried version 3.2… same thing. When i try to close the error window it opens the link to Liberica JDK which seems weird. Am I getting screwed?


On the second screenshot I see that you’re trying to use a ZIP distro. Why?

The first screenshot is probably a screenshot of the installer for Windows which, as I guess, says that it can’t overwrite javaw.exe file. Did you try removing any older installations of GanttProject, if there were any?

In my opinion, it makes sense to talk to some tech savvy guy next to you who knows how to install and remove programs on Windows. Chances are that it will lead to success faster than exchanging screenshots on the forum.

HI to all

Since my problem occured i reinstalled version 3.1.3100 and by miracle, it works ok. Tried before version 3.2… but had the same problem. So for the time being I will stick with 3.1.3100.