Hard dependency does not move task / group start

I made a chart of my typical project workflow to give me some better visualization of where I’m at. Basically I’m a Ressource of one hence everything has to be in a row.

I made all folowing task dependend on the former. I’d expect the software to automatically shift start/end of the tasks when the dependency is edited. But it works only in one direction. I can make a task longer so all the following tasks start later but not the other way round.

Interesstingly it worked once to change the hard dependency to a weak one and back. Then it shifted everything as expected. But it worked only once.

I attached the file. Maybe sb can have a look and show me where my problems are.

It’s about the following groups after the milestones.

Projektplanung 2021.gan (25,7 KB)

It seems to be this bug:

I already found that Bug Tracker Entry. First one was closed due to expected behavior, the second one is open, but in your last comment you reference to the closed (not)bug.

So basically I’m doing nothing wrong? Sorry for all the texts being german :slight_smile:

Thank you for your really fast response!

Nope, nothing wrong.
There’s an easy workaround: draw a dependency not to the summary task, but to its first child task instead.

Ok, thank you very much for your great support!


Hi Dimitrij,
i tried it, but it won’t solve my issue. Even though i removed the dependency from the summary task and assigned any child to the former process it will not move the start-date. The only solution is to delete all dependencies, and reassign them all. But this is somehow annyoing. Can you comprehend this behavior? If you got a better method, please let me know.

Thank you.

The workaround works fine in my test in your project: