Problem w/ XML files


(Michał Rogowski) #1

Hi,
I can’t open .XML files saved in MS Project. I can’t as well export project to MS Project XML file. No matter what I do - it never saves file.
Is there any fix to it?
Regards,
Michal


(Dmitry Barashev) #2

Assuming that you open MS Project files in GanttProject using Project->Import menu item, and assuming that you export using Project->Export, we’d like to know more what does it mean: “no matter what i do - it never saves file”. If export completes successfully, and file/folder is writable, it writes a file. If it doesn’t, it shows error messages.

What exactly do you do? Do you get any error messages? Is there anything suspicious in the log (Help->View log)? Where do you search for the file?


(Michał Rogowski) #3

Well, I tested it a bit longer and it looks like the GIVEN .XML file was not OK.
I couldn’t open it, but I could import it to an empty project I created.
Then I saved it as .XML file and then - tadaaamm - I could open it!
So - this issue is no more an issue :slight_smile:

Now assume that I opened successfully saved .XML file. I made some minor changes and tried to EXPORT it to MS Project .XML file.
[Project->Export->MS Project button (.XML)->Browse to target directory->Enter path or folder name]

  • in “Files” widow I SEE NO .XML FILES (which are there actually) - window is empty
  • I enter the filename SOMETHING.XML - and nothing happens (literally).

But maybe I misunderstand the meaning of “export”? Could you comment?

Michal


(Dmitry Barashev) #4

“Browse” button lets you choose target folder where the file will be written to. By default it is the same folder where your GanttProject file sits, so you can just skip changing the folder. File chooser which opens when you click “Browse” by default shows folders and “.mpx” and “.xml” files. If you want to see all files in the file chooser, select “All files” in the dropdown box. In any case, most likely the file which you want to write doesn’t exist yet (unless you’re going to overwrite existing) so you need to choose a name for the file. When you decided where you want to export the file, you need to click “OK” to start the export.