Export to MS Project 2016


(James Mills) #1

Hi, wonder if you can help…

I have been using GanttProject for a while now and have recently bought MS Project 2016, only to find that I can’t export a project in MPX file format from GanttProject to Project 2016 as the latter doesn’t support this format, only older versions do!

Is there any way around this?

Please note that I am not particularly IT literate and am self taught so laymans terms appreciated, thanks.


(Dmitry Barashev) #2

Why don’t you use Microsoft’s XML format aka MSPDI?


(James Mills) #3

Hi Dmitry

Thanks for your reply, I have tried this but when I go to open it all I get is a Notepad document with pages and pages of text! Am I missing something obvious?


(Dmitry Barashev) #4

Notepad document? When you export to XML you get, well, XML. Yes, it is nearly plain text and can be opened in Notepad, but you’ll want to open it in MS Project. There must be a menu action for that © in MS Project. I guess it is File->Open (can’t check, sorry).


(James Mills) #5

Hi

Did try opening from MS Project but Project shut down and restarted, when I tried for a second time I received a message that the last time had caused a serious error. I’ve tried with some other GanttProject XML files and the same happens.It appears that my GanttProject files are corrupted maybe?


(Dmitry Barashev) #6

I don’t think so. Can’t say anything certain without seeing the real behavior and error messages, sorry.

I’ve tried with some other GanttProject XML files

Just in case: don’t open GanttProject files in MS Project. Open what GanttProject exports to MS Project XML.


(James Mills) #7

Hi

I saved the project to my desktop as XML file, then opened MS Project, clicked Open Other Projects>Browse and searched Desktop for all files and found the XML file. Clicked Open, Import wizard asks if I want to save as new project, I click finish and then the error message came up. If I ask still to open it then Project closes and restarts.


(Dmitry Barashev) #8

Looks weird.
I think you need to make sure that all Project updates are installed. As far as I can see from their public updates, crashes because of this or that reason are not rare.

If it won’t help or if you already have all the latest updates, please send us the original .gan file and the produced MS Project XML. No promises, but maybe we’ll figure out what’s wrong.


(James Mills) #9

Hi

Thanks for your comments, I’ve checked that all updates are installed but still the problem persists. What is the email address to use to send the files to you?

Many thanks


(Dmitry Barashev) #10

contact@ganttproject.biz


(Andy Stubbs) #11

Any update to this? I have the same problem.

thanks,
Andy


(Dmitry Barashev) #12

The reason of crashes were two resource custom columns with empty names.


(Ray Robey) #13

Is there any update to a fix?

i am having the same problem.


(Dmitry Barashev) #14

As written above, this issue was caused by custom columns with empty names. If you’re having the same problem, try applying the same fix: rename custom columns so that they were not empty.


(Ray Robey) #15

There are no custom columns being used. I have only selected name, Begin date, End date and Duration.


(Dmitry Barashev) #16

Selected? MS Project Export exports all columns, you can’t select a subset. There are other columns besides those which are shown in the table. You can find them with “Manage Columns” action in the context menu on the table header.

Please pay attention that resources may also have custom columns (which was the case for the topic starter).
Empty custom columns may appear without explicit actions e.g. by importing not very tidy CSV file.

Anyway, if you’re certain that there are no custom columns with empty names in your project, please send the project file to the email address written above.


#17

I am having the same problem.

I have made none of such custom column.
100% using ganttproject software and trying to import for microsoft project but to no avail.


(Dmitry Barashev) #18

Your file exports fine in my tests with the latest GanttProject 2.8.7.