Importing csv file

I have used the Export function to determine the file format for the tasks and the resources. The tasks seem to import okay but none of my attempts, and I’ve tried it probably 4 dozen times, have I been successful in importing resources.

Each time I try the import I make slight changes thinking that maybe there’s something wrong with the data’s format but I can’t even import data that I entered manually into GanttProject and exported to import back into a new blank project file.

Is there some trick or steps that I need to take first? Do all the roles need to be defined first? Doa ll the columns need to have data?

I’m running 2.8.8

Can you share the CSV file?

FOREP.csv (2.5 KB)
Attached…

Any thoughts as to why this won’t import?

Oh, thanks for reminding.
GanttProject expects both tasks and resources sections to be in the file, separated by two empty lines. Even if CSV has no tasks, there must be task headers line. Inserting these three lines (headers + two empty) in the head of your CSV fixes the issue:

-- Begin here --
ID,Name,Begin date,End date


-- End here ---

Ok, that really helped… I also found that when Excel saves to a csv file, it adds additional commas to the resource heading when the tasks section has more column headings than the resource section. This then causes errors when importing. I’ve since used Notepad++ to clean up my Excel csv files.

Hopefully this will be fixed with new export/import directly to XLS files

Hi

I am issue upload my csv please help.

Gantt - 12 Oct - Sheet1.csv (691 Bytes)

Can you please explain what do you expect from us? This CSV is not in the format which is understood by GanttProject. You can see the expected format by exporting any project (e.g. our standard HouseBuildingSample) to CSV.

Hi there,
I’m trying to import a csv file into a new project but keep receiving the following error:
Failed to parse date 26/03/2018 . Date is expected to have format dd/MM/yy (e.g. today is 21/12/18 ). You can change date format in the settings dialog

I’ve created a file based on the specs of a GanttProject export and also used the same date format. After importing all dates are set to today’s date, everything else seems to be working fine (haven’t yet tried adding resources to the import file though). The date settings in GanttProject are the same as in my file. What am I doing wrong? :frowning:
I appreciate any help

Sorry, everyone! I was an idiot and didn’t check my settings properly! Changed my settings and now the dates are imported as well.
I still have a problem though. When I add the resources to the file I get an error “Failed to parse value=Phone”
I’ve tried removing the commas as JimDandy mentions, but that just results in a whole new set of errors.

Any ideas what’s wrong?
GP_import-tasks-test.csv (1.4 KB)
GP_import-tasks-test_log.txt (13.2 KB)

Lines separating tasks from resources must be empty (you have commas in them). Also, you have a number of trailing commas in the header of the resource section. Remove them all.

Dear all,
I follow your instruction but I’ve a problem importing the xls file into gantt project.
my problem is that the dates are not imported correclty, the month is never take into consideration, I tryed to change the csv file from dd/mm/yy (or dd/mm/yyyy) to mm/dd/yy (or mm/dd/yyyy) but it never import it correctly
image

can you suggest something?
Thank you.
RegardsWBS_prova_ganttProject.csv (1,7 KB)

Most likely you need to set your date format in GanttProject settings to dd/MM/yyyy (MM uppercased). mm stands for minutes of hour. MM stands for month of year.

1 Like

Thank you for the suggestion!!
It works!

A post was split to a new topic: CSV from Xavier Delplanque