Task font illegibile / aliasing in 3.2.3240

Greets – I’ve just updated to 3.2.3240, and now I can’t read the task font very well on my external monitor (3840 x 2160). It seems to be aliasing severely. I’ve tried adjusting font in ganttproject settings, but it’s not helping.

  1. Is there a way to address this issue?

  2. Ganttproject v2.8 is still installed on my machine and it displays my projects just fine.
    Is there a way to “revert” so that double-clicking a *.gan file will run Ganttproject v2.8 again (instead of v3.2)? I suspect that is more of a windows11 question than a ganttproject question, but any assistance would be gratefully received.


Did you try changing the font size or font family? Can you post a screenshot or a photo showing the issue?

Talking about the file association, you can just uninstall both GP versions and install GP 2.8 again.

Hi Dmitry (sorry for the late reply). Yes, I’ve played around with font size and family, but wasn’t able to find a good one.

  1. Here is the latest version. This is displayed on my external monitor (1920 x 1080). Note that the text seems to alias a bunch. I’ve pasted is a .png of the image (not a jpg) so hopefully this email will show the actual blurriness I actually see. Pretty tiring for the eyes. By the way, my native laptop display 3840 x 2160 shows the text clearly – just too small for my old eyes.


  1. Here is v2.8 on my external monitor. Much clearer – I also like that it is more compact (less space per line).


Any ideas?

Is everything fine on the main monitor?

If you’re on Windows, can you please try adding these two lines to the end of file ganttproject.l4j.ini in the root folder of your GanttProject installation:


Thanks Dmitry – tried, but I don’t seem to have permissions to save – can you remind me how to get permissions (windows 11)


I suspect that you need to be the Administrator to edit such files. If you installed GanttProject by yourself, you probably know how to become the Administrator.

Thanks Dmitry (ran into permissions issues and wasn’t sure if there was something unique to this app, but was able to edit)
Adding the lines worked. Fonts are now legible as in previous version! Thank you very much.

Is everything okay on the main laptop display too?

Same issue when I upgraded to 3.2.3246 (didn’t note the previous version) display fonts got all scraggly.
Windows 11, UW monitor resolution 2560X1080
This solution worked fine! thanks

I ran into the same problems in version 3.2.3247 when I ran it on my windows 11 machine. Can confirm that the proposed solution works, thanks a lot! The font really got close to illegible in my case. Would it be possible to include this solution in future versions? Or does it cause problems for other windows versions?

that works, thank you

FYI - problem with jagged text on secondary monitor persists in version 3.3.3300 and .3003, but your solution no longer works… it worked with previous version (3.2. - the one available to winget repo).
Problem is on my Windows 11 where primary laptop monitor has different SCALE than secondary (external) - app looks fine on big monitor when the same increased SCALE is set for both monitors.
With 125% on laptop and 100% scale on external monitor, app text looks BAD on secondary monitor.

May I ask you to try running another Java application and test if it behaves similarly? It is a Scene Builder, an app that helps with building user interfaces. You can download it from here: